Uploaded image for project: 'ActivityInfo'
  1. AI-2040

Users with "Default" Partners are not copied correctly when copying an existing databases

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - next release
    • Resolution: Fixed
    • Fix versions: 2.20.1893
    • Components: API
    • Labels:
      None

      Description

      • Database A has User 1, associated with the "Default" Partner
      • User creates a new Database B, using Database A as a template and copying all Partners and User Permissions

      Expected Behaviour
      User 1 should be copied to Database B, and associated with the new Default Partner on Database B.

      Current Behaviour
      User 1 is copied to Database B, but remains associated with Database A's Default Partner.

      Root Cause

      • When copying partners, the default partner on Database A is omitted from the cloning procedure.
      • A new Default Partner is created for Database B.
      • However when a User is copied to the new Database B, the procedure does not update the User's partner to the new Default Partner.

        TestRail: Results

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jamie Jamie Whitehouse (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  TestRail: Cases